return

Задача №6.5

29 октября 2012, 20:51

Маршрутизатор в Москве анонсирует всем остальным маршрутизаторам в сети маршрут по умолчанию. Но на все остальные маршрутизаторы он приходит с одинаковой метрикой равной 1 и метрика не увеличивается по пути передачи маршрута.
Для удобства решено было изменить настройки по умолчанию таким образом, чтобы начальная метрика маршрута по умолчанию была 30 и по пути, с передачей маршрута по умолчанию по сети, к начальной метрике добавлялась стоимость пути. Кроме того, в дальнейшем возможно добавление резервного маршрутизатора в Москве, с которого на провайдера будет указывать ещё один маршрут по умолчанию. Резервный маршрутизатор будет использоваться только если пропадет основной, поэтому маршруты по умолчанию, которые они анонсируют должны быть с разными метриками.
Ответ не торопитесь открывать.

like 0 views 11028 message 14

14 коментариев

  • Здравствуйте.
    Давайте сначала с 2.2 разберёмся.

    Дам вам подсказку: какие IP-параметры вы настраиваете на ПК, какие на коммутаторе? Чего не хватает?

    За добрые слова спасибо!

    2 октября 2013, 17:22
  • Ничего. Удачи!

    9 октября 2013, 19:00
  • Марат, спасибо большое!
    Дырявая моя голова!

    9 октября 2013, 11:40
  • Причём здесь свитчи? Говоря о линках, я имею ввиду L3 линки между маршрутизаторами. То есть вы должны в Москве в маршруте на Кемерово указывать адрес интерфейса, который «смотрит» в сторону Кемерова, то есть 2.18, если я правильно помню IP-адресацию.

    7 октября 2013, 17:43
  • но как же так, если на свичах у нас не висят адреса?
    а как раз с роутера Мск до роутера в Кемерово аккурат 2 свича.
    Запутался я чего-то.

    7 октября 2013, 17:04
  • 172.16.24.0 255.255.255.240 172.16.24.1

    Это что означает? Если это маршрут, то он неверен. Маршрутизатор должен знать, как добраться до адреса Next-hop, а 24.1 ему неизвестен. Тут должен быть линковый адрес.
    Причём адрес именно этого линка — никакого другого. То есть в сторону Москвы из Кемерово вы тоже не можете указывать маршрут через 172.16.2.1 — потому что Кемерово не знает, что это за адрес.

    7 октября 2013, 12:51
  • Здравствуйте.

    7 октября 2013, 12:49
  • Марат, рад приветствовать в осенний понедельник.
    Не могу понять, что я делаю не так в маршрутизации между Мск и Кмр.
    по идее не должно быть проблем: даем сеть т.е. 172.16.24.0 255.255.255.240 172.16.24.1
    А в Кемерово наоборот… на 172.16.2.0 255.255.255.252. 172.16.2.1
    или нет?

    и на asw3 настраиваем дефолт гейтвей на роутер msk. Указываю 172.16.0.1 — не видит все равно.

    Подскажи, что не так?

    Спасибо

    7 октября 2013, 12:46
  • Ну как сказать, решился. Когда будет достойный Job Offer, тогда и решусь 🙂

    А просто в Москву ради Москвы не тянет.

    4 октября 2013, 18:17
  • оффтопик:
    ты решился таки перебраться в Москву?
    я пару лет назад сюда переехал)

    4 октября 2013, 10:23
  • Не вопрос)

    На самом деле я часто делаю паузу специально. Часто этого времени человеку хватает, чтобы он сам разобрался — а это гораздо ценнее совета)

    3 октября 2013, 18:24
  • Так.С 2.2 разобрался. ISP перенастроил.пакетики побежали)
    на 16.1 пинги через раз.
    Чую, еще не один раз обращусь к Вам, чтобы в голову информация плотно засела))

    Спасибо, что быстро ответили в первый раз.

    3 октября 2013, 18:06
  • Меня зовут Марат. Это, кстати, написано на страничке Эбаут.

    Извините, неправильно понял вопрос. Давненько уже статья писалась — забыл.

    А пинг непосредственно между 2.1 и 2.2 есть?

    3 октября 2013, 18:05
  • Знать бы Ваше имя, обращался бы по нему, а то по нику как-то не комильфо.
    2.2 это ведь у нас ip на подинтерфейсе на spbgw.
    считай, прямой канал до 2.1 — тот что на подинтерфейсе на mskgw.
    что там может быть не так?
    Может, действительно конфиг на isp кривой?:
    version 12.1
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Switch
    !
    !
    spanning-tree mode pvst
    !
    interface FastEthernet0/1
    switchport trunk allowed vlan 4-5
    switchport mode trunk
    !
    interface FastEthernet0/2
    switchport trunk allowed vlan 4
    !
    interface FastEthernet0/3
    switchport trunk allowed vlan 5

    3 октября 2013, 09:53

Ещё статьи

Анонс подкаста. Выпуск 70 \\\\\15.12 16:00 Мск.
Сетевой подкаст linkmeup всегда несёт чистые знания — структурированный доклад на какую-нибудь тему от одного-двух гостей. 70-й выпуск будет другим. Мы решили, что такую тему, как Сетевая Автоматизация просто невозможно ...
like 0 3291 2
10 декабря 2018
Ответ к задаче №МВ3.9
Конфигурация R1: router bgp 64500 no synchronization bgp log-neighbor-changes network 100.0.0.0 mask 255.255.254.0 neighbor AS64500 peer-group neighbor AS64500 remote-as 64500 neighbor AS64500 update-source Loopback0 neighbor AS64500 next-hop-self neighbor 2.2.2.2 peer-group ...
like 0 2619 0
4 ноября 2013
Анонс подкаста. Выпуск 21
Продолжим хорошее начинание — 16-го ноября слушайте онлайн 21-й выпуск подкаста linkmeup. Тема выпуска очень долгожданная — поговорим о системах мониторинга, управления, инвентаризации итд. От самых маленьких домовых сетей до ...
like 0 5484 13
10 ноября 2014