return

Задача №8.10

24 июня 2013, 11:44

Схема:
Условие: Никакого BGP. ЛинкМиАп использует статические маршруты к провайдерам.
На маршрутизаторе msk-arbat-gw1 настроена PBR: HTTP-трафик должен идти через провайдера Филькин Сертификат, а трафик из сети 10.0.2.0 должен идти через Балаган Телеком.
Указанный трафик передается правильно, но не маршрутизируется остальной трафик из локальной сети, который должен передаваться через провайдера Балаган Телеком.
Задание:
Исправить настройки таким образом, чтобы они соответствовали условиям.
Конфигурация:

hostname msk-arbat-gw1
interface Loopback1
ip address 10.0.1.1 255.255.255.0
ip nat inside
!
interface Loopback2
ip address 10.0.2.1 255.255.255.0
ip nat inside
!
interface FastEthernet0/0
description Balagan_Telecom_Internet
ip address 101.0.0.2 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
description Philkin_Certificate_Internet
ip address 102.0.0.2 255.255.255.252
ip nat outside
speed 100
full-duplex
!
!
ip access-list extended LAN
permit ip 10.0.1.0 0.0.0.255 any
permit ip 10.0.2.0 0.0.0.255 any
!
route-map BALAGAN permit 10
match ip address LAN
match interface FastEthernet0/0
route-map PH_CERT permit 10
match ip address LAN
match interface FastEthernet0/1
!
ip nat inside source route-map BALAGAN interface Fa0/0 overload
ip nat inside source route-map PH_CERT interface Fa0/1 overload
!
ip access-list extended HTTP
permit tcp any any eq 80
!
ip access-list extended LAN2
permit ip 10.0.2.0 0.0.0.255 any
!
route-map PBR permit 10
match ip address HTTP
set ip next-hop 102.0.0.1
route-map PBR permit 20
match ip address LAN2
set ip next-hop 101.0.0.1
!
ip local policy route-map PBR

 

Ответ будет позже.

like 0 views 112 message 2

2 коментария

  • Добрый день, Николай.
    Мне бы тоже хотелось бы написать продолжение этой темы, но пока нет подходящего материала.
    Сама утилита scapy использовалась и в других моих статья — про атаки на протоколы OSPF и HSRP.
    А так, из последнего — сейчас у редактора на обработке находится статья про IPsec.
    Обычно происходит как — или в процессе работы или в процессе обучения, попадается интересная тема, по которой проходит небольшое исследование, и в итоге появляется новая статья.
    Иногда тему для нового материала подсказывают читатели 🙂

    8 апреля 2015, 14:08
  • 1)
    ip route 0.0.0.0 0.0.0.0 101.0.0.1
    !
    route-map PBR permit 30

    2)
    route-map PBR permit 30
    set ip next-hop 101.0.0.1

    3)
    no route-map PBR permit 20
    !
    ip route 0.0.0.0 0.0.0.0 101.0.0.1

    24 июня 2013, 16:21

Ещё статьи

Новый проект: телекоммуникационный глоссарий
Друзья, читатели, слушатели, мы бы хотели сообщить о том, что в этом году у нас стартует новое направление: Глоссарий. Это будет самый полный и самый удобный справочник по телекоммуникационным терминам ...
like 123 4769 8
20 января 2014
Анонс подкаста. Выпуск 46
Когда: 25.12.2016 в 15:00 Кто: Евгений Хабаров. Скромно о себе: ведущий сетевой администратор в одной из крупнейших Российских аутсорсинговых ИТ компаний. Про что: Тшут. Философия устранения неисправностейОткуда берутся проблемы, типы ...
like 0 5188 5
15 декабря 2016
Бесчеловечные сети
Статья опубликована на nag.ru и на habrahabr.ru. ======================== Когда-то управление автомобилем было почти искусством. Во времена славной классики (шестёрок и пятёрок) нужно было знать, как прочистить карбюратор, заменить топливный насос ...
like 0 14395 16
29 октября 2013