return

Задача №8.10

24 июня 2013, 17:22

Схема:
Условие: ЛинкМиАп использует статические маршруты к провайдерам (не BGP).
На маршрутизаторе msk-arbat-gw1 настроена PBR: HTTP-трафик должен идти через провайдера Филькин Сертификат, а трафик из сети 10.0.2.0 должен идти через Балаган Телеком.
Указанный трафик передается правильно, но не маршрутизируется остальной трафик из локальной сети, который должен передаваться через провайдера Балаган Телеком.
Задание:
Исправить настройки таким образом, чтобы они соответствовали условиям.
Конфигурация:

hostname msk-arbat-gw1

interface Loopback1
ip address 10.0.1.1 255.255.255.0
ip nat inside
!
interface Loopback2
ip address 10.0.2.1 255.255.255.0
ip nat inside
!
interface FastEthernet0/0
description Balagan_Telecom_Internet
ip address 101.0.0.2 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
description Philkin_Certificate_Internet
ip address 102.0.0.2 255.255.255.252
ip nat outside
speed 100
full-duplex
!
!
ip access-list extended LAN
permit ip 10.0.1.0 0.0.0.255 any
permit ip 10.0.2.0 0.0.0.255 any
!
route-map BALAGAN permit 10
match ip address LAN
match interface FastEthernet0/0
route-map PH_CERT permit 10
match ip address LAN
match interface FastEthernet0/1
!
ip nat inside source route-map BALAGAN interface Fa0/0 overload
ip nat inside source route-map PH_CERT interface Fa0/1 overload
!
ip access-list extended HTTP
permit tcp any any eq 80
!
ip access-list extended LAN2
permit ip 10.0.2.0 0.0.0.255 any
!
route-map PBR permit 10
match ip address HTTP
set ip next-hop 102.0.0.1
route-map PBR permit 20
match ip address LAN2
set ip next-hop 101.0.0.1
!
ip local policy route-map PBR

Ответ.

like 0 views 6399 message 1

1 коментарий

  • В задаче сказано

    Указанный трафик передается правильно, но не маршрутизируется остальной трафик из локальной сети

    однако не маршрутизируется вообще ни какой трафик, в том чисе и указанный. В таблице маршрутизации отсутвуют какие-либо записи.

    msk-arbat-gw1#sh ip route
    Codes: C — connected, S — static, R — RIP, M — mobile, B — BGP
    D — EIGRP, EX — EIGRP external, O — OSPF, IA — OSPF inter area
    N1 — OSPF NSSA external type 1, N2 — OSPF NSSA external type 2
    E1 — OSPF external type 1, E2 — OSPF external type 2
    i — IS-IS, su — IS-IS summary, L1 — IS-IS level-1, L2 — IS-IS level-2
    ia — IS-IS inter area, * — candidate default, U — per-user static route
    o — ODR, P — periodic downloaded static route

    Gateway of last resort is not set

    102.0.0.0/30 is subnetted, 1 subnets
    C 102.0.0.0 is directly connected, FastEthernet0/1
    101.0.0.0/30 is subnetted, 1 subnets
    C 101.0.0.0 is directly connected, FastEthernet0/0
    10.0.0.0/24 is subnetted, 2 subnets
    C 10.0.2.0 is directly connected, Loopback2
    C 10.0.1.0 is directly connected, Loopback1

    29 января 2018, 15:45

Ещё статьи

Сети для самых маленьких. Часть нулевая. Планирование
Все выпуски12. Сети для самых маленьких. Часть двенадцатая. MPLS L2VPN 11.1. Сети для самых маленьких. Микровыпуск №6. MPLS L3VPN и доступ в Интернет 11. Сети для самых маленьких. Часть одиннадцатая. ...
like 16 3526 108
29 октября 2012
Анонс подкаста. Выпуск 66 \\\\\Выпуск состоялся. Публикация 25.08
В предстоящем выпуске вас ждёт ещё один российский производитель — «Код Безопасности». Именно из под их станков выходят СКЗИ АПКШ «Континент». Разработчики рвутся причинить сообществу пользу рассказом о том, как ...
like 369 2807 0
30 июля 2018
linkmeup и Миран. Или что происходит с главной 2.
Самые внимательные уже заметили перемены на главной и даже нашли им объяснение. На этот раз к нам приехал логотип Мирана, и наконец-то пропали мертворожденный Форум и завершённый CCIE за год. ...
like 0 2967 0
26 марта 2018