return

Ответ к задаче №8.3

19 июля 2013, 07:49
router bgp 64500
no synchronization
bgp log-neighbor-changes
network 100.0.0.0 mask 255.255.254.0
neighbor 101.0.0.1 remote-as 64501
neighbor 101.0.0.1 prefix-list LAN out
neighbor 102.0.0.1 remote-as 64502
neighbor 102.0.0.1 prefix-list LAN out
no auto-summary
!
ip route 100.0.0.0 255.255.254.0 Null0
!
ip prefix-list LAN permit 100.0.0.0/23
like 0 views 13379 message 17

17 коментариев

  • Леонид Воронкин

    Должны поддерживать. Вот только моему процу больше 7 лет 🙂

    8 августа 2015, 20:15
  • Леонид Воронкин

    Приветствую ещё раз. Я разобрался со своей проблемой. Списывался с одним из разрабов unetlab он меня просветил. Может тоже полезным будет. QEMU образы не будут работать (как и у меня) если CPU компа не имеет аппаратную поддержку виртуализации (Intel VT-X или AMD-V). Будут работать только IOU образы. Я на работе развернул на компе с i5 всё завелось. Проверил, вроде все заявленные функции есть. Я тогда не обратил внимание на представленные вами скриншоты, только сейчас посмотрел. Синтаксис команды ip dhcp-snooping. А arp-protect старая команда. Сейчас ip arp inspection

    8 августа 2015, 18:21
  • Леонид Воронкин

    Всюду обман.
    То что GNS поддерживает vIOS это здорово. Но это не отменяет желания разобраться с Unetlab. У него преимущество в виде многопользовательского режима — удобно учебные стенды делать. Плюс ему можно подпихнуть и vASA, и IOSxrv, и CRS, а не как в GNS отдельные виртуалки плодить. А это всё тоже под QEMU работает.
    Ну раз у кого-то работает, значит у меня руки не от туда.

    13 июля 2015, 15:42
  • Решил не дожидаться и посмотреть сразу же в GNS (внезапно оказалось он тоже умеет запускать vIOS из коробки)

    Ну вообщем работает то L2vIOS нормально, но обещанных фич я не нашел.

    Увы.

    12 июля 2015, 23:15
  • Леонид Воронкин

    На счёт IOU я тупил, извиняюсь. Забыл выставить права на скрипт когда лицензию генерил.
    Может кто из знакомых подсовывал в UNL vIOS. Если не сложно будет спросите у товарищей по оружию.
    Я делал как тут http://www.ccienetlab.com/labs/15-kak-importirovat-obrazy-iz-cisco-virl-v-unetlab.html
    Не вышло

    12 июля 2015, 21:19
  • Добрый день. Я еще не пробовал ставить Unetlab.
    В прошлом году проект был в бете, я за ним особо не следил, а теперь вот вроде уже вполне стабильно работает.
    Наверное уже можно пробовать и смотреть.
    Что касается лицензии, наверное нужно сгенерить ключ и где-то положить на файловую систему.
    В мануале пишут следующее: «License must be stored under the same path: /opt/unetlab/addons/iol/bin/iourc
    [license]
    unl01 = 0123456789abcdef;»
    Что касается vIOS не подскажу, не смотрел.
    Логи по идее могут быть в каталоге /var/log
    Точный путь уже зависит от разработчика.
    Я лично последний год использовал GNS3, он тоже научился цепляться к IOU.
    Сейчас он часто обновляется, но иногда бывают баги.
    У меня специфический юзкейс, большие топологии мне нужны редко.
    А вот хороший L2 мне бы не помешал, поэтому EOS-коммутатор меня и заинтересовал.
    Его можно взять отдельной виртуальной машиной.
    eos.arista.com/veos-running-eos-in-a-vm/
    Насколько он превосходит L2 IOU это видимо нужно уже смотреть.

    12 июля 2015, 20:39
  • Настроил при помощи AS-Path ACL:

    router bgp 64500
    no synchronization
    bgp log-neighbor-changes
    network 100.0.0.0 mask 255.255.254.0
    network 100.0.0.0 mask 255.255.255.0
    network 100.0.1.0 mask 255.255.255.0
    neighbor 101.0.0.1 remote-as 64501
    neighbor 101.0.0.1 filter-list 100 out
    neighbor 102.0.0.1 remote-as 64502
    neighbor 102.0.0.1 filter-list 100 out
    no auto-summary
    !
    ip route 100.0.0.0 255.255.254.0 Null0
    ip route 100.0.0.0 255.255.255.0 Null0
    ip route 100.0.1.0 255.255.255.0 Null0
    !
    ip as-path access-list 100 permit ^$

    7 сентября 2013, 11:31
  • Приветствую!
    Про особенности QEMU не знал.
    Хотя с другой стороны наверное все процессоры выпущенные за последние лет 6 должны поддерживать аппаратную виртуализацию.
    Да спасибо, действительно я проверял ночью и наделал ошибок.

    Работает вполне себе неплохо, атаки обнаруживает.


    Это достаточно хорошая вещь, так как студенты очень часто спрашивают и просят показать защиту от ARP пойзонинга.

    8 августа 2015, 20:03
  • Да, ресурс известный.
    Иногда там беру электронные книжки.

    12 июля 2015, 22:46
  • Да, конечно на unetlab.
    Хорошо, если всё заработает, то сообщу.

    12 июля 2015, 22:43
  • Леонид Воронкин

    Здесь можно взять vIOS. И вообще много полезного. Наверное знаете этот ресурс.
    certcollection.org/forum/topic/264060-cisco-viosvios-l2-from-virl-4262015/

    12 июля 2015, 22:43
  • Я некоторое время не следил за ситуацией, видимо произошли некоторые изменения.
    Я в курсе что такое IOU и vIOS.
    Насколько я помню VIRL легально продавался за 200$ или около того.
    Про то, что IOU уже не делают я не знал. А что же тогда инженеры тех поддержки циски используют? Тоже VIRL получается.
    Мне стало интересно, поэтому завтра — послезавтра сам попробую собрать себе vIOS и посмотреть, что они умеют.

    12 июля 2015, 22:28
  • Леонид Воронкин

    Всё правильно говорите. Virl платный. Есть бесплатная демоверсия. А что инженеры циски используют не знаю. Возможно нас обманывают, но последний L2-IOU датирован 2013 годом. L3 есть 2015 года версия 15.5.2.
    Я так понимаю vIOS будете в unetlab разворачивать. Поделитесь пожалуйста потом как всё получилось.

    12 июля 2015, 22:40
  • Леонид Воронкин

    Не понял вопрос. Наверное вечер уже поздний. IOU — скомпилированный под линукс IOS. vIOS это ios для VIRL — какая то своя цисковская приблуда. Если честно не вдавался в подробности что из себя физически представляет. На счёт того что VIRL более урезанный не сказал бы. IOU образы новые уже не делают, а vIOS точат по сей день. Тем более сами говорите что «Я вот смотрю DHCP Snooping есть, а вот в оригинальном L2 IOU я подобную фичу не находил…». (Не могу сейчас сходу это подтвердить). Вот то что хавает больше — это да.

    12 июля 2015, 22:12
  • А у меня тогда к вам вопрос 🙂
    Чем отличаются vIOS-L2 от L2 IOU?
    Наверное от VIRL еще более урезанный?
    Я вот смотрю DHCP Snooping есть, а вот в оригинальном L2 IOU я подобную фичу не находил…

    12 июля 2015, 21:44
  • Леонид Воронкин

    Да вот в том то и дело. Что в мануале сразу откуда-то iourc взялся. Ни генерили ни в ручную не создавали. Когда я ставил. Идёшь по инструкции и естественно он ниоткуда не появляется. Генератор от IOU не подходит. В ручную тоже не подпихивается. Во общем тёмный лес. Им надо у вас поучится инструкции писать 😉
    Раз ещё не пробовали ставить, тогда больше не отвлекаю.

    12 июля 2015, 20:53
  • У каждой задачи несколько решений.

    7 сентября 2013, 11:36

Ещё статьи

Ответ к задаче №МВ3.3
R1: router bgp 64500 neighbor 101.0.0.1 remote-as 64501 neighbor 101.0.0.1 remove-private-as R2: router bgp 64500 neighbor 102.0.0.1 remote-as 64502 neighbor 102.0.0.1 remove-private-as
like 0 5562 3
19 октября 2013
Big Monitoring Meetup
А мы к вам снова с рассказом про конференцию! На этот раз физически всё будет в Санкт-Петербурге, но организаторы обещают организовать трансляцию, так что доступна она будет всем. Итак, Big ...
like 0 2480 0
3 июля 2017
Ответ к задаче №8.5
interface FastEthernet0/0description Balagan_Telecom_Internetip address 101.0.0.2 255.255.255.252bandwidth 9000!interface FastEthernet0/1description Philkin_Certificate_Internetip address 102.0.0.2 255.255.255.252bandwidth 3000!!router bgp 64500no synchronizationbgp log-neighbor-changesbgp bestpath as-path multipath-relaxmaximum-paths 2bgp dmzlink-bwnetwork 100.0.0.0 mask 255.255.254.0neighbor 101.0.0.1 remote-as 64501neighbor 101.0.0.1 prefix-list ...
like 0 7612 4
19 июля 2013