return

Задача №МВ3.2

15 октября 2013, 10:20

Между AS64504 и AS64509 появился линк, который связывает их напрямую. Обе сети использовали OSPF и без проблем объединили сеть в одно целое. Но, после проверки, оказалось, что трафик ходит через AS64500, а не напрямую от AS64504 к AS64509, через OSPF.
Изменить конфигурацию BGP:
— R7 должен использовать OSPF, если трафик идет в сеть 109.0.0.0/24
— R9 должен использовать OSPF, если трафик идет в сеть 104.0.0.0/24
Дополнительный вопрос: Зачем в настройках loopback настроен тип сети OSPF point-to-point?
Изменения в настройках R7, R9, R3:
R7

hostname R7
!
interface Loopback1
ip address 104.0.0.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/
ip address 100.0.0.6 255.255.255.252
!
interface FastEthernet0/1
ip address 192.168.255.7 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 104.0.0.0 0.0.0.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
router bgp 64504
no synchronization
bgp log-neighbor-changes
network 104.0.0.0 mask 255.255.255.0
neighbor 100.0.0.5 remote-as 64500
no auto-summary
!

R9

hostname R9
!
interface Loopback0
ip address 109.0.0.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 192.168.255.9 255.255.255.0
!
interface FastEthernet0/1
ip address 100.0.0.10 255.255.255.252
!
router ospf 1
log-adjacency-changes
network 109.0.0.0 0.0.0.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
router bgp 64509
no synchronization
bgp log-neighbor-changes
network 109.0.0.0 mask 255.255.255.0
neighbor 100.0.0.9 remote-as 64500
no auto-summary
!

R3

hostname R3
!
router bgp 64500
neighbor 100.0.0.10 remote-as 64509

Ответ.

Комментарии к задачам закрыты. Если у вас есть ответ или вопросы или вам просто не с кем поговорить на технические темы, пишите на адрес: natasha@linkmeup.ru.

like 0 views 8671 message 5

5 коментариев

  • Дополнительный вопрос: Зачем в настройках loopback настроен тип сети OSPF point-to-point?

    interface Loopback1

    ip address 104.0.0.1 255.255.255.0

    ip ospf network point-to-point

    без команды ip ospf network point-to-point
    анонс будет выгладить 104.0.0.1/32

    а с ней как 104.0.0.0/24

    16 октября 2013, 09:02
  • По мне самое красивое решение это

    R7
    network 109.0.0.0 mask 255.255.255.0 backdoor

    R9
    network 104.0.0.0 mask 255.255.255.0 backdoor

    и R3 не надо дергать.

    16 октября 2013, 08:59
  • из-за того что у EBGP-маршрута AD=20, а у OSPF 110, верно?

    15 октября 2013, 15:10
  • Вы правы!
    Спасибо за ответ.

    16 октября 2013, 09:10
  • Наташа Самойленко

    Да. И суть задачи в том, чтобы не задевая все остальные маршруты (OSPF и BGP), исправить ситуацию так, чтобы трафик ходил через прямой линк, через OSPF.
    (только не пишите, пожалуйста, ответ сюда. Пусть другие тоже подумают :))

    15 октября 2013, 15:40

Ещё статьи

linkmeup ⑤ лет
Меж тем при температуре -34 за окном незаметно протекает пятилетие linkmeup. За это время набралось 4,6 млн просмотров 600к посетителей790к скачиваний подкастов6 млн минут просмотров видео на youtube.3к подписчиков вкМнохамноха ...
like 0 4959 4
22 декабря 2016
Анонс подкаста sysadmins. Выпуск 11. Резервное копирование и все все все \\\\27.04 ...
Наконец-то началась весна, а в linkmeup_sysadmin решили в очередной раз поразбираться в «уже давно разобранных темах». Мы хотим поговорить о такой заезженной штуке, как бекап. Планируем обсудить: — Академические вопросы ...
like 421 5970 2
22 апреля 2019
Задача №8.8
Схема: Условие: ЛинкМиАп использует статические маршруты к провайдерам (не BGP).Конфигурация. Маршрутизаторы провайдеров также не используют BGP.Задание: Настроить переключение между провайдерами.Маршрут по умолчанию к Балаган Телеком должен использоваться до тех пор, ...
like 0 13435 0
24 июня 2013