return

Ответ к задаче №МВ3.2

19 октября 2013, 12:12

На маршрутизаторе R7:

router bgp 64504
network 109.0.0.0 mask 255.255.255.0 backdoor

На маршрутизаторе R9:

router bgp 64509
network 104.0.0.0 mask 255.255.255.0 backdoor
like 0 views 8448 message 6

6 коментариев

  • Привет.
    Залинкую тебя на мамонта: t.me/LoxmatiyMamont
    Он ведёт рубрику.

    4 января 2019, 10:33
  • Еще как вариант можно увеличить AD маршрута OSPF

    R9
    access-list 10 permit 104.0.0.0 0.0.0.255
    router ospf 1
    distance 19 130.0.0.1 0.0.0.0 10

    6 марта 2016, 18:27
  • Не знал про параметр backdoor. Решил задачу таким образом:

    R7
    ip access-list standard R9_LAN
    permit 109.0.0.0 0.0.0.255
    router bgp 64504
    distance 111 100.0.0.5 0.0.0.0 R9_LAN

    R9
    ip access-list standard R7_LAN
    permit 104.0.0.0 0.0.0.255
    router bgp 64509
    distance 111 100.0.0.9 0.0.0.0 R7_LAN

    29 мая 2015, 03:28
  • Наташа Самойленко

    Спасибо пользователю ulypka007 за ответы. Они были правильными. Мы их удалили, чтобы дать возможность другим подумать.
    Ваши ответы были такими:

    По мне самое красивое решение это
    R7
    network 109.0.0.0 mask 255.255.255.0 backdoor

    R9
    network 104.0.0.0 mask 255.255.255.0 backdoor

    и R3 не надо дергать.
    Дополнительный вопрос: Зачем в настройках loopback настроен тип сети OSPF point-to-point?
    interface Loopback1
    ip address 104.0.0.1 255.255.255.0
    ip ospf network point-to-point

    без команды ip ospf network point-to-point
    анонс будет выгладить 104.0.0.1/32
    а с ней как 104.0.0.0/24
    ulypka007

    3 ноября 2013, 15:58
  • Наташа Самойленко

    Ответ на дополнительный вопрос об OSPF: Команда ip ospf network point-to-point нужна для того, чтобы OSPF анонсировал сеть loopback-интерфейса с той маской, которая задана на интерфейсе. Если не указать эту команду, то OSPF анонсирует сети loopback с маской /32

    3 ноября 2013, 15:54
  • Хотя при использовании параметра backdoor вывод show ip bgp rib-failure отображает ту же причину, что и при увеличении AD с помощью access-list’а — RIB-failure: Higher admin distance. Получается параметр backdoor тоже увеличивает AD.

    29 мая 2015, 04:22

Ещё статьи

Сети для самых маленьких. Часть вторая. Коммутация
Все выпуски12. Сети для самых маленьких. Часть двенадцатая. MPLS L2VPN 11.1. Сети для самых маленьких. Микровыпуск №6. MPLS L3VPN и доступ в Интернет 11. Сети для самых маленьких. Часть одиннадцатая. ...
like 18 7184 117
1 ноября 2012
linkmeup 4 года
Принято отсчитывать возраст Linkmeup с даты публикации нулевого выпуска СДСМ на хабре — ровно 4 года назад. Сегодня у нас: 12 главных выпусков в цикле. Все выпуски10. Сети для самых ...
like 0 3429 6
22 декабря 2015
Безопасность IP телефонии
Статья написана специально для linkmeup. ======================= Здравствуйте, коллеги и друзья, я, Семенов Вадим, совместно с командой проекта network-class.net представляем вниманию обзорную статью, которая затрагивает основные тенденции и угрозы в IP ...
like 0 16451 9
30 июля 2014