return

Задача №10.1

22 декабря 2014, 14:35

В сети настроена простая политика QoS, в которой IP-пакеты, которые идут с хоста 10.0.17.7 на адрес 6.6.6.6, маркируются и передаются по сети MPLS. Для маркировки пакетов используется поле TC (EXP), значение поля 3.
На маршрутизаторе R6 настроена политика QoS, которая классифицирует пакеты по полю TC (EXP).
Но, при проверке оказалось, что политика на R6 не отрабатывает. То есть, нет пакетов, приходящих со значением TC (EXP) 3 и все пакеты попадают в class default.
Задание: Исправить конфигурацию так, чтобы политика на R6 срабатывала.
Схема:
К схеме статьи добавлен маршрутизатор R7, который используется в качестве клиента. Соответственно MPLS между R7 и R1 не включен.
Конфигурация маршрутизаторов R2,R3,R4,R5 базовая
Добавлен маршрутизатор R7, в роли клиента.
На маршрутизаторах R1 и R6 настроены политики QoS.
Конфигурация R7:

hostname R7
!
interface FastEthernet0/0
ip address 10.0.17.7 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.0.17.1

Конфигурация R1:
!
hostname R1
!
class-map match-all GROUP_3
match qos-group 3
class-map match-all ACL_MATCH
match access-group name QoS
!
policy-map POLICY_MPLS
class ACL_MATCH
set qos-group 3
policy-map OUT_MPLS
class GROUP_3
set mpls experimental topmost 3
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip router isis
!
interface FastEthernet0/0
description to R2
ip address 10.0.12.1 255.255.255.0
ip router isis
mpls ip
service-policy output OUT_MPLS
!
interface FastEthernet0/1
description to R3
ip address 10.0.13.1 255.255.255.0
ip router isis
mpls ip
!
interface FastEthernet1/0
description to R7
ip address 10.0.17.1 255.255.255.0
ip router isis
service-policy input POLICY_MPLS
!
router isis
net 10.0000.0000.0001.00
!
ip access-list extended QoS
permit ip host 10.0.17.7 host 6.6.6.6
!
mpls ldp router-id Loopback0 force

Конфигурация R6:

hostname R6
!
class-map match-all MATCH_EXP_3
match mpls experimental topmost 3
!
policy-map MPLS_IN
class MATCH_EXP_3
set qos-group 3
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
ip router isis
!
interface FastEthernet0/0
description to R5
ip address 10.0.56.6 255.255.255.0
ip router isis
mpls ip
service-policy input MPLS_IN
!
router isis
net 10.0000.0000.0006.00
!
mpls ldp router-id Loopback0 force

 

Подсказка

 

Дополнительная информация:

Ответ будет опубликован позже.

Комментарии к задачам закрыты. Если у вас есть ответ или вопросы или вам просто не с кем поговорить на технические темы, пишите на адрес: natasha@linkmeup.ru

like 0 views 13494 message 0

0 коментариев

Ещё статьи

Призы от Mikrotik в подкасте linkmeup#47
Пока мы подумываем, а не начать ли разыгрывать сувенирку в подкастах, Mikrotik взял и предвосхитил эту идею. Итак, во время эфира 47-го выпуска подкаста для связистов Linkmeup, будет вручено три ...
like 0 3727 2
19 января 2017
Ответ к задаче №МВ3.8
Для проверки политик на R7 такие настройки: router bgp 64504 network 130.0.0.0 mask 255.255.255.0 neighbor 100.0.0.5 remote-as 64500 neighbor 100.0.0.5 send-community neighbor 100.0.0.5 route-map ISP out ! route-map ISP permit ...
like 0 5098 2
19 октября 2013
Анонс подкаста sysadmins. Выпуск 9. ИБ в ИТ, начало \\\\27.01 18:00 Мск
Мы решили-таки сделать безопасный выпуск в linkmeup_sysadmins. Начнем с фундаментальных понятий о всеми нами любимых безопасных людях, которые стоят на страже интересов организации. Какими они бывают, защитники своих ЗО, бдят ...
like 404 5025 1
23 января 2019