Задача №МВ3.7

Наш новый клиент AS 64504 подключен к нашей сети. И пока что не планирует подключение к другому провайдеру. На данном этапе клиент может использовать номер автономной системы из приватного диапазона. Блок адресов, который использует клиент, будет частью нашего диапазона сетей.
Задание: Так как сеть клиента является частью нашего блока адресов, надо чтобы сеть клиента не анонсировалась соседним провайдерам.
Не использовать фильтрацию префиксов или фильтрацию по AS для решения этой задачи.
Конфигурация и схема: Community.
Отличия только в том, что сеть, которую анонсирует AS64504: 100.0.1.0/28, а не 130.0.0.0/24

Ответ.

Комментарии к задачам закрыты. Если у вас есть ответ или вопросы или вам просто не с кем поговорить на технические темы, пишите на адрес: natasha@linkmeup.ru.

Задача №МВ3.6

Необходимо изменить стандартную процедуру выбора лучшего маршрута на маршрутизаторах в AS64500:
— маршрутизаторы R1 и R2 должны выбирать маршруты eBGP, а не iBGP, независимо от длины AS path,
— маршрутизаторы R3 и R4 внутри автономной системы должны выбирать маршруты на основании метрики OSPF.

Конфигурация и схема: базовые.

Ответ.

Комментарии к задачам закрыты. Если у вас есть ответ или вопросы или вам просто не с кем поговорить на технические темы, пишите на адрес: natasha@linkmeup.ru.

Задача №МВ3.5

Вышестоящая AS 64503 агрегирует несколько сетей, в том числе и нашу, в один диапазон 100.0.0.0/6. Но этот суммарный префикс вернулся в нашу автономную систему, хотя и не должен был.
Так выглядит префикс 100.0.0.0/6 в таблице BGP на R1:

R1#sh ip bgp
Network Next Hop Metric LocPrf Weight Path
* i 100.0.0.0/23 2.2.2.2 0 100 0 i
*> 0.0.0.0 0 32768 i
* i 4.4.4.4 0 100 0 i
* i 3.3.3.3 0 100 0 i
* i 100.0.0.0/6 2.2.2.2 0 100 0 64502 64503 i
*> 101.0.0.1 0 64501 64503 i
*> 101.0.0.0/20 101.0.0.1 0 0 64501 i
*>i 102.0.0.0/21 2.2.2.2 0 100 0 64502 i
* 101.0.0.1 0 64501 64502 i
*>i 130.0.0.0/24 4.4.4.4 0 100 0 64504 i


Настроить R8 так, чтобы агрегированный префикс не попадал в таблицу BGP маршрутизаторов, которые анонсируют подсети этого префикса. Не использовать фильтрацию для этого.

Конфигурация и схема: базовые.
На R8 дополнительно настроено следующее:

router bgp 64503
aggregate-address 100.0.0.0 252.0.0.0 summary-only


Ответ.

Комментарии к задачам закрыты. Если у вас есть ответ или вопросы или вам просто не с кем поговорить на технические темы, пишите на адрес: natasha@linkmeup.ru.

Задача №МВ3.4

Необходимо настроить такие правила работы с соседними AS:
— от всех соседних AS принимаются префиксы только если в них количество автономных систем в пути не более 10 (в реальной жизни порядок этого значения может быть около 100).
— все префиксы, которые принимаются от клиентов, должны быть с маской не более 24 бит.
Конфигурация и схема: базовые.

Ответ.

Комментарии к задачам закрыты. Если у вас есть ответ или вопросы или вам просто не с кем поговорить на технические темы, пишите на адрес: natasha@linkmeup.ru.

Задача №МВ3.3

Наш новый клиент AS 65504 подключен к нашей сети. И в дальнейшем планирует подключение к другому провайдеру и у него уже есть свой PI-блок адресов. Но на данном этапе, есть подключение только к нашей AS и поэтому клиент может использовать приватный номер AS.
Задание: При анонсе сети клиента вышестоящим провайдерам, удалить номер приватной AS65504.
Конфигурация и схема: базовые.
Отличие — номер клиентской AS — 65504.

Ответ.

Комментарии к задачам закрыты. Если у вас есть ответ или вопросы или вам просто не с кем поговорить на технические темы, пишите на адрес: natasha@linkmeup.ru.

Задача №МВ3.2

Между AS64504 и AS64509 появился линк, который связывает их напрямую. Обе сети использовали OSPF и без проблем объединили сеть в одно целое. Но, после проверки, оказалось, что трафик ходит через AS64500, а не напрямую от AS64504 к AS64509, через OSPF.
Изменить конфигурацию BGP:
— R7 должен использовать OSPF, если трафик идет в сеть 109.0.0.0/24
— R9 должен использовать OSPF, если трафик идет в сеть 104.0.0.0/24



Дополнительный вопрос: Зачем в настройках loopback настроен тип сети OSPF point-to-point?

Изменения в настройках R7, R9, R3:

R7
hostname R7
!
interface Loopback1
ip address 104.0.0.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/
ip address 100.0.0.6 255.255.255.252
!
interface FastEthernet0/1
ip address 192.168.255.7 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 104.0.0.0 0.0.0.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
router bgp 64504
no synchronization
bgp log-neighbor-changes
network 104.0.0.0 mask 255.255.255.0
neighbor 100.0.0.5 remote-as 64500
no auto-summary
!


R9
hostname R9
!
interface Loopback0
ip address 109.0.0.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 192.168.255.9 255.255.255.0
!
interface FastEthernet0/1
ip address 100.0.0.10 255.255.255.252
!
router ospf 1
log-adjacency-changes
network 109.0.0.0 0.0.0.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
router bgp 64509
no synchronization
bgp log-neighbor-changes
network 109.0.0.0 mask 255.255.255.0
neighbor 100.0.0.9 remote-as 64500
no auto-summary
!

R3
hostname R3
!
router bgp 64500
neighbor 100.0.0.10 remote-as 64509


Ответ.

Комментарии к задачам закрыты. Если у вас есть ответ или вопросы или вам просто не с кем поговорить на технические темы, пишите на адрес: natasha@linkmeup.ru.

Задача №МВ3.1

Схема:



В таком сценарии у нас два BGP-маршрутизатора R1 и R3, но они находятся в разных концах города и подключены через промежуточный маршрутизатор, на котором BGP не настроен.

Условие:
IBGP-сессия прекрасно установится, несмотря даже на то, что на промежуточном маршрутизаторе BGP не включен, и мы видим даже маршруты:


Но где пинг?



Ответ.

Комментарии к задачам закрыты. Если у вас есть ответ или вопросы или вам просто не с кем поговорить на технические темы, пишите на адрес: natasha@linkmeup.ru.

Задача №МВ3.8

В нашей AS для настройки политик с клиентскими AS, используются community. Используются такие значения: 64500:150, 64500:100, 64500:50, 64500:1, 64500:2, 64500:3.
Кроме того, маршрутизаторы нашей AS также используют community для работы с соседними AS. Их формат: 64501:xxx, 64502:xxx.
Задание:
— все значения community приходящие от клиентов, которые не определены политикой, должны удаляться,
— значения community, которые проставлены клиентами, должны удаляться, при передаче префиксов соседним вышестоящим AS. При этом не должны удаляться другие значения, которые проставлены маршрутизаторами нашей AS.

Конфигурация и схема: базовые.

Ответ.

Комментарии к задачам закрыты. Если у вас есть ответ или вопросы или вам просто не с кем поговорить на технические темы, пишите на адрес: natasha@linkmeup.ru.

Задача №8.10

Схема:



Условие: ЛинкМиАп использует статические маршруты к провайдерам (не BGP).

На маршрутизаторе msk-arbat-gw1 настроена PBR: HTTP-трафик должен идти через провайдера Филькин Сертификат, а трафик из сети 10.0.2.0 должен идти через Балаган Телеком.
Указанный трафик передается правильно, но не маршрутизируется остальной трафик из локальной сети, который должен передаваться через провайдера Балаган Телеком.

Задание:
Исправить настройки таким образом, чтобы они соответствовали условиям.

Конфигурация:
hostname msk-arbat-gw1

interface Loopback1
ip address 10.0.1.1 255.255.255.0
ip nat inside
!
interface Loopback2
ip address 10.0.2.1 255.255.255.0
ip nat inside
!
interface FastEthernet0/0
description Balagan_Telecom_Internet
ip address 101.0.0.2 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
description Philkin_Certificate_Internet
ip address 102.0.0.2 255.255.255.252
ip nat outside
speed 100
full-duplex
!
!
ip access-list extended LAN
permit ip 10.0.1.0 0.0.0.255 any
permit ip 10.0.2.0 0.0.0.255 any
!
route-map BALAGAN permit 10
match ip address LAN
match interface FastEthernet0/0
route-map PH_CERT permit 10
match ip address LAN
match interface FastEthernet0/1
!
ip nat inside source route-map BALAGAN interface Fa0/0 overload
ip nat inside source route-map PH_CERT interface Fa0/1 overload
!
ip access-list extended HTTP
permit tcp any any eq 80
!
ip access-list extended LAN2
permit ip 10.0.2.0 0.0.0.255 any
!
route-map PBR permit 10
match ip address HTTP
set ip next-hop 102.0.0.1
route-map PBR permit 20
match ip address LAN2
set ip next-hop 101.0.0.1
!
ip local policy route-map PBR


Ответ.

Задача №8.3

Схема: Текущая схема сети
Условие: Full View на всех маршрутизаторах

Если вы сейчас посмотрите таблицу BGP на маршрутизаторе провайдера Балаган Телеком, то увидите 3 маршрута в сеть 102.0.0.0/21 — сеть Филькина Сертификата. И один из маршрутов ведёт через нашу сети ЛинкМиАп.



Это говорит о том, что наш бордер анонсирует чужие маршруты дальше, иными словами наша AS является транзитной.

Задание:
Настроить фильтрацию таким образом, чтобы наша AS64500 перестала быть транзитной.

Ответ.