return

Сети для самых маленьких. Часть первая (которая после нулевой). Подключение к оборудованию cisco

30 октября 2012, 16:52
Все выпуски

Сегодня мы обратимся к части немного скучной, но важной для начинающих: как подключиться, поставить или сбросить пароль, войти по telnet. Также рассмотрим существующие программы — эмуляторы ciscо и интерфейс оборудования.
Как и обещали, в этот раз всё по-взрослому: с видео.

Под катом то же в текстовой и чуть более подробной форме.
Итак, вот они приехали — заветные коробки с надписью Cisco на борту.

Среда

Начнём с того, в какой среде будем работать.
В данный момент есть два известных пакета программ, позволяющих моделировать сеть, построенную на оборудовании Cisco:
а) Цисковский же продукт Packet Tracer, который по идее свободно не распространяется. Это эмулятор и имеет лишь некоторые функции Cisco IOS. Вообще говоря, он сильно ограничен и многие вещи в нём реализованы лишь отчасти. Никаких тонких настроек. С другой стороны к настоящему моменту версия 5.3.2 поддерживает создание GRE-туннелей, протоколов динамической маршрутизации (и в их числе даже BGP!). Притом он очень прост в освоении и имеет в своём арсенале сервера (FTP, TFTP, DHCP, DNS, HTTP, NTP, RADIUS, SMTP, POP3), рабочие станции и свичи. Сейчас уже есть под Linux, хотя в былые времени он прекрасно запускался и из-под Wine.
б) Распространяемый по лицензии GNU GPL симулятор GNS3. В этом пакете необходимо загружать настоящие образы Cisco IOS. С одной стороны это плюс – вы работаете с настоящим интерфейсом cisco и ограничены лишь своей фантазией, существующими стандартами и производительностью рабочей станции, с другой, во-первых, эти IOS ещё нужно суметь достать, во-вторых, это более сложный продукт для понимания, и в-третьих, в нём есть только маршрутизаторы и «типа» коммутаторы.
Я считаю, что для знакомства с принципами лучше начать всё же с Packet Tracer’a, а потом переходить на тяжёлую артиллерию по мере надобности. Все мы не дети малые, где взять то, что нам нужно, рассказывать не будем.

Способы подключения

В Packet Tracer’e управлять оборудованием можно следующими способами:

  • GUI
  • CLI в окне управления
  • Терминальное подключение с рабочей станции через консольный кабель
  • telnet

Интерфейс последних трёх идентичный – отличается лишь способ подключения. Разумеется, GUI – не наш метод.
В реальной же жизни доступны:

  • Telnet/ssh
  • Терминальное подключение с рабочей станции через консольный кабель
  • Web-интерфейс (Cisco SDM).

Последний вариант даже не упоминайте в приличном обществе. Даже если вы адепт мыши и браузера, очень не советую.
На своём примере при работе с другим оборудованием я сталкивался с тем, что настроенное через веб не работает. Хоть ты тресни, но не работает. А у того же длинка вообще был баг в одной версии прошивки для свичей: если изменить настройки VLAN в веб-интерфейсе из под линукс, то свич становится недоступным для управления. Это официально признанная проблема).
Телнет – стандартная, всем известная утилита, как и ssh. Для доступа к cisco по этим протоколам нужно настроить пароли доступа, об этом позже. Возможность использования ssh зависит от лицензии IOS.

Управление по консоли

Ну вот принесли вы маршрутизатор, распечатали, питание на него дали. Он томно зашумел кулерами, подмигивает вам светодиодами своих портов. А чего дальше-то делать?
Воспользуемся один из древнейших и нестареющих способов управления практически любым умным устройством: консоль. Для этого вам нужен компьютер, само устройство и подходящий кабель. Тут каждый вендор на что горазд. Какие только разъёмы они не используют: RJ-45, DB-9 папа, DB-9 мама, DB-9 с нестандартной распиновкой, DB-25.
У циски используется разъём RJ-45 на стороне устройства и DB-9 мама (для подключения к COM-порту) на стороне ПК.
Консольный порт выглядит так: Консольный порт cisco Консольный порт cisco Всегда выделен голубым цветом. С недавних пор стало возможным управление по USB.
А это консольный кабель cisco: Консольный кабель cisco Раньше он поставлялся в каждой коробке, теперь зачастую стоит отдельных денег. В принципе подходит аналогичный кабель от HP.
Проблема в том, что современные ПК зачастую не имеют COM-порта. На выручку приходят часто используемые конвертеры USB-to-COM: Либо редко используемые для этих целей конвертеры RS232-Ethernet После того, как вы воткнули кабель, определили номер COM-порта, для подключения можно использовать Hyperterminal или Putty в Виндоус и Minicom в Линукс.
Управление через консоль доступно сразу, а вот для телнета нужно установить пароль. Как это сделать?
Обратимся к PT.
Начнём с создания маршрутизатора: выбираем его на панели внизу и переносим на рабочее пространство. Даём какое-нибудь название c2811 Что бы вы делали, если бы это был самый взаправдашний железный маршрутизатор? Взяли бы консольный кабель и подключились им в него и в компьютер. То же самое сделаем и тут: Packet tracer console Packet tracer console Кликом по компьютеру вызываем окно настройки, в котором нас интересует вкладка Desktop. Далее выбираем Terminal, где нам даётся выбор параметров Впрочем, все параметры по умолчанию нас устраивают, и менять их особо смысла нет.
Если в энергонезависимой памяти устройства отсутствует конфигурационный файл (startup-config), а так оно и будет при первом включении нового железа, нас встретит Initial Configuration Dialog prompt: cisco interface Вкратце, это такой визард, позволяющий шаг за шагом настроить основные параметры устройства (hostname, пароли, интерфейсы). Но это неинтересно, поэтому отвечаем no и видим приглашение

Router>

Это стандартное совершенно для любой линейки cisco приглашение, которое характеризует пользовательский режим, в котором можно просматривать некоторую статистику и проводить самые простые операции вроде пинга. Ввод знака вопроса покажет список доступных команд: Грубо говоря, это режим для сетевого оператора, инженера первой линии техподдержки, чтобы он ничего там не повредил, не напортачил и лишнего не узнал. Гораздо большие возможности предоставляет режим с говорящим названием привилегированный. Попасть в него можно, введя команду >enable. Теперь приглашение выглядит так:

Router#

Здесь список операций гораздо обширнее, например, можно выполнить одну из наиболее часто используемых команд, демонстрирующую текущие настройки устройства ака “конфиг” #show running-config. В привилегированном режиме вы можете просмотреть всю информацию об устройстве.
Прежде, чем приступать к настройке, упомянем несколько полезностей при работе с cisco CLI, которые могут сильно упростить жизнь:
— Все команды в консоли можно сокращать. Главное, чтобы сокращение однозначно указывало на команду. Например, show running-config сокращается до sh run. Почему не до s r? Потому, что s (в пользовательском режиме) может означать как команду show, так и команду ssh, и мы получим сообщение об ошибке % Ambiguous command: «s r» (неоднозначная команда).
— Используйте клавишу Tab и знак вопроса. По нажатию Tab сокращенная команда дописывается до полной, а знак вопроса, следующий за командой, выводит список дальнейших возможностей и небольшую справку по ним (попробуйте сами в PT).
— Используйте горячие клавиши в консоли:
Ctrl+A — Передвинуть курсор на начало строки
Ctrl+E — Передвинуть курсор на конец строки
Курсорные Up, Down — Перемещение по истории команд
Ctrl+W — Стереть предыдущее слово
Ctrl+U — Стереть всю линию
Ctrl+C — Выход из режима конфигурирования
Ctrl+Z — Применить текущую команду и выйти из режима конфигурирования
Ctrl+Shift+6 — Остановка длительных процессов (так называемый escape sequence)
— Используйте фильтрацию вывода команды. Бывает, что команда выводит много информации, в которой нужно долго копаться, чтобы найти определённое слово, например. Облегчаем работу с помощью фильтрации: после команды ставим |, пишем вид фильтрации и, собственно, искомое слово(или его часть). Виды фильтрации (ака модификаторы вывода):
begin — вывод всех строк, начиная с той, где нашлось слово,
section — вывод секций конфигурационного файла, в которых встречается слово,
include — вывод строк, где встречается слово,
exclude — вывод строк, где НЕ встречается слово.
Но вернемся к режимам. Третий главный режим, наряду с пользовательским и привилегированным: режим глобальной конфигурации. Как понятно из названия, он позволяет нам вносить изменения в настройки устройства. Активируется командой #configure terminal из привилегированного режима и демонстрирует такое приглашение:

Router(config)#

В режиме глобальной конфигурации не выполняются довольно нужные порой команды других режимов (тот же show running-config, ping, etc.). Но есть такая полезная штука, как do. Благодаря ей мы можем, не выходя из режима конфигурирования, выполнять эти самые команды, просто добавляя перед ними do. Примерно так:

Router(config)#do show running-config

Настройка доступа по Telnet

Из этого-то режима мы и настроим интерфейс для подключения компьютера через telnet:
Команда для перехода в режим конфигурации интерфейса FastEthernet 0/0:

Router(config)# interface fa0/0

По умолчанию все интерфейсы отключены (состояние administratively down). Включаем интерфейс:

Router(config-if)#no shutdown

Настроим IP-адрес:

Router(config-if)#ip address 192.168.1.1 255.255.255.0

shutdown — означает “выключить интерфейс”. Соответственно, если вы хотите отменить действие команды, то используйте слово no перед ней. Это правило общее для CLI и применимо к большинству команд.
Подключаемся. Для этого надо использовать кроссоверный кабель. (Хотя в реальной жизни это зачастую уже необязательно – все карточки умеют понимать приём/передачу, однако встречаются ещё маршрутизаторы, порты которых не поднимаются при использовании неправильного типа кабеля — так что будьте внимательны) crossover cable Настраиваем IP-адрес компьютера через Desktop. IP адрес И пробуем подключиться, выбрав Command Prompt в панели Desktop: Packet Tracer telnet Как и ожидалось, циска не пускает без пароля. В реальной жизни обычно выдаёт фразу “Password required, but none set”

Пароли

Подключение по telnet или ssh называется виртуальным терминалом (vt) и настраивается следующим образом:

Router(config)#line vty 0 4 Router(config-line)#password cisco
Router(config-line)#login

0 4 — это 5 пользовательских виртуальных терминалов=telnet сессий.
Этого уже достаточно, чтобы попасть в пользовательский режим, но недостаточно для привилегированного: Packet Tracer telnet Настроим пароль для enable-режима:

Router(config)#enable secret test

Packet Tracer Чем отличается secret от password? Примерно тем же, чем ssh от telnet. При настройке secret пароль хранится в зашифрованном виде в конфигурационном файле, а password – в открытом. Поэтому рекомендуется использование secret.
Если вы всё-таки задаёте пароль командой password, то следует применить так же service password-encryption, тогда ваш пароль в конфигурационном файле будет зашифрован:

line vty 0 4 password 7 08255F4A0F0A0111

Один мой знакомый рассказал мне историю:
Стоял он как-то курил возле одного из своих узлов, находящемся в жилом доме. С сумкой для инструментов, ноутбук в руках. Вдруг подходит двое алкашей с пакетом и предлагают купить, раскрывая пакет и показывая какой-то свич. Просят 500 рублей. Ну он купил. По меткам и модели свича парень сделал вывод какому провайдеру он принадлежит. Пришёл домой, начал ковырять — телнет закрыт, консоль запаролена. Слил конфиг по snmp. Пароли в открытом виде хранятся, имя с головой выдаёт провайдера. С их админом он знаком лично, позвонил ему вместо “Здрасьти” выдал логин и пароль в трубку. Слышно было, как скрипел мозг первые секунд 20: везде аксес-листы, авторизация, привязка к мак-адресу. Как?! В общем, всё хорошо, что хорошо кончается.

Немного об этом можно почитать здесь. Ну или чуть более по-русски, тут.
Хотим обратить ваше внимание:
сейчас принятно настраивать доступы не через виртуальные терминалы, а командами #username и #aaa new-model. В версии PT 5.3.2 они уже есть и вполне работают.
Для этого нужно выполнить:

Router(config)#aaa new-model
Router(config)#username admin password 1234

Первая команда служит для активации новой модели ААА (Authentication, Authorization, Accounting). Это нужно для того, чтобы была возможность использовать для аунтетификации на устройстве RADIUS или TACACS сервер. Если отдельно это не настроено, то будет использоваться локальная база пользователей, задаваемая командой username.
Будьте внимательны: приоритет команды aaa new-model выше, чем команд виртуальных терминалов и поэтому даже несмотря на то, что у вас настроен password в режиме line vty, если у вас не будет пользователей в локальной базе, зайти на устройство удалённо уже не получится.
Теперь при подключении маршрутизатор запросит имя пользователя и соответствующий ему пароль.
При более глубокой настройке line vty существует одна опасность.
Есть такой параметр: access-class. Его настройка позволяет ограничить IP-адреса, с которых возможно подключение. И вот однажды я, как умная маша, решил заняться безопасностью в сети и на всём почти оборудование понаставил эти аксес-листы, чтобы комар не пролетел. В один прекрасный момент пришлось выехать в поле и в тот день я проклял свою аккуратность – никуда не мог достучаться – малейшей лазейки не оставил. В общем будьте с этой командой внимательны или оставляйте для себя лазейки.
При работе с access-list’ами и прочими опасными вещами, неправильная настройка которых может лишить вас доступа к устройству, можно использовать замечательную команду reload in min, где min время в минутах. Эта команда перезагрузит устройство по истечении указанного времени, если ее не прервать командой reload cancel. Т.е. схема работы такова: вы удаленно копаете что-то, что может в теории (закон Мерфи не забываем) прервать ваш сеанс связи с устройством. Сохраняем текущий (рабочий) конфиг в startup-config (он используется при загрузке), ставим reload in 15, вводим ключевую команду, относительно которой у нас сомнения ;-), и получаем обрыв связи, худшие опасения оправдались. Ждем 15 минут, устройство перегружается с рабочим конфигом, коннект — вуаля, связь есть. Либо (если связь не прервалась) проверяем, что все работает, и делаем reload cancel.
Если вы хотите ограничить паролем доступ через консольный порт, вам понадобятся команды

Router(config)#line console 0
Router(config-line)#login
Router(config-line)#password cisco

Privilege Level

Ещё один важный момент, которому в статьях уделяют мало внимания: privelege level.
Как понятно из латинского звучания — это уровень прав пользователя. Всего существует 16 уровней: 0-15.
privilege level 0 — это команды disable, enable, exit, help и logout, которые работают во всех режимах
privilege level 1 — Это команды пользовательского режима, то есть как только вы попадаете на циску и увидите приглашение Router> вы имеете уровень 1.
privilege level 15 — Это команды привилегированного режима, вроде, как root в Unix’ах

Пример1

Router(config)#line vty 0 4
Router(config-line)privilege level 15

После входа на маршрутизатор при такой настройке вы сразу увидите Router# со всеми вытекающими правами.
Все уровни со 2 по 14 настраиваются вручную. То есть, например, вы можете дать добро пользователю с privelege level 2 на выполнение команды show running-config

Пример2

Настроить права для конкретного пользователя поможет уже упомянутая прежде команда username

Router(config)#username pooruser privilege 2 secret poorpass
Router(config)#privilege exec level 2 show running-config
Router(config)#enable secret level 2 l2poorpass

В первой строке назначаем уровень прав пользователю, во второй команду, разрешенную для этого уровня, в третьей задаём пароль для входа в привилегированный режим с этим уровнем.
После этого из пользовательского режима вы можете выполнить команду enable 2 и введя пароль l2poorpass попасть в привилегированный режим, в котором будут доступны все команды уровня 1 + команды уровня 2. Для чего это может быть нужно? В российских реалиях практически ни для чего, потому что обычно на устройство нужно заходить инженерам сразу с полными правами. Ну разве что 15-й уровень ставят, чтобы двойную аутентификацию не проходить. А все другие уровни опять же для того, чтобы персонал младшего состава (техподдержка, например) мог зайти и промониторить какие-то параметры или настроить некритичную функцию.

SSH

Нельзя не упомянуть о том, что telnet — протокол незащищённый и передаёт пароль и данные в открытом виде. С помощью любого анализатора пакетов можно вычислить пароль. Поэтому крайне рекомендуем использовать ssh — любые устройства cisco с не самой урезанной прошивкой способны выступать ssh-сервером.
Следующий набор команд позволит вам включить ssh и отключить доступ по telnet:

Router(config)#hostname R0
R0(config)#ip domain-name cisco-dmn
R0(config)#crypto key generate rsa
R0(config)#line vty 0 4
R0(config-line)#transport input ssh

Имя хоста должно отличаться от Router, обязательно должно быть задано имя домена. Третьей строкой генерируется ключ и далее разрешается только ssh. Длина ключа должна быть более 768 бит, если вы желаете использовать ssh версии 2, а вы желаете этого. Всё.
Ещё одно финальное внимание новичкам: не забывайте о команде write memory — это сохранение текущей конфигурации. Впрочем, достаточно два раза обжечься, забыв сохранить, чтобы навсегда заработать иммунитет к этому — кто кодил по ночам или писал курсовую, тот поймёт.
Используя PT, мы будем настраивать оборудование не через терминал или телнет, а непосредственно через CLI устройства, которое вызывается кликом по иконке роутера — так удобнее: CLI

Ну и на сладенькое: сброс пароля

Так, а что же делать, если на стол легла вам бушная циска с неизвестным паролем или вы очень невовремя забыли его? Вообще-то это многократно описано и легко гуглится, но повторить это необходимо. Практически на любом сетевом устройстве есть возможность сбросить пароль, имея физический доступ. Если сделать это невозможно или это отдельная платная услуга, то скорее всего в ваших руках находится какая-то русская поделка (не в обиду, конечно, нашим производителям, но дважды я такие строки читал в документации:))
Итак, cisco:
1) Подключаетесь к устройству консольным кабелем,
2) Отправляете его в ребут (хоть по питанию, хоть командой #reload)
3) Когда на экране побежит такая строчка ########…###, означающая загрузку образа (40-60 секунд после включения), необходимо отправить сигнал Break. Как это сделать в разных программах читать тут. Вы попадаете в режим ROMMON. 4) В этом режиме введите команду: confreg 0x2142, она заставит устройство игнорировать startup-config при загрузке.
5) Введите reset для перезагрузки
6) После загрузки running-config будет девственно чистым, а startup-config содержит по-прежнему последнюю сохранённую конфигурацию. Сейчас самое время поменять пароль или слить конфиг. 7) Самое важное: верните обратно регистры:

Router(config)#config-register 0x2102

Если вы этого не сделаете, то вся ваша конфигурация будет актуальна до первого ребута) И хорошо, если это устройство стоит рядом, и вы вспомните, что накосячили. Мне не повезло)
В следующей статье мы обратимся к вланам и локальной сети. Обязательно к прочтению:
OSI.
VLAN
Незарегистрированные читатели Хабрахабра могут задать свои вопросы в ЖЖ.

Хочу поблагодарить Максима aka gluck за помощь в написании этой статьи.

like 16 views 2548 message 61

61 коментарий

  • Александр Гаценко

    Добрый день, всем!
    Дико извиняюсь за некропостинг, но всё же. Только начал потихоньку изучать сети и смотреть ваши уроки. Сделал всё как указано в вашем уроке и возникла следующая вопрос-задача.
    Имеется три пользователя: Admin, user1 и user2. Admin имеет полный доступ, user1 только команды show, user2 команды show+возможность конфига портов.
    Собственно вопрос, как сделать так чтобы когда я заходил под админом я сразу попадал в 15 привилегии, а когда под user1 и user2, то попадал в привилегии 2 и 3 соответственно.
    Конфиг роутера сейчас такой (добавил текстовый файл на ЯД чтобы не захламлять пост): Конфиг в текстовом файле.

    26 сентября 2020, 19:36
  • Дмитрий Максименко

    можно использовать замечательную команду reload in min, где min время в минутах.

    в PT 7.1.0 на устройстве 2811 что-то не работает команда «reload in» или «reload cancel»
    только «reload» и все

    6 апреля 2018, 09:59
  • Здравствуйте! Уважаемые.
    Столкнулся с проблемой, забыл пароль к роутеру.
    Пробовал как описано выше сбросить пароль, в результате сбрасывается весь конфиг.
    Помогите пожалуйста.

    5 января 2017, 10:57
  • Георгий Владимиров

    небольшое наблюдение. скажем, есть дефолтный конфиг на 2950-24 в пт такого вида:

    line vty 0
    password cisco
    login
    line vty 1 4
    login
    line vty 5 15
    login

    если ломится одновременно двумя пк на циску, то пока на терминале (vty 0) первого висит запрос пароля до истечения таймаута, второй пк заходит на неё без пароля (vty 1)

    13 августа 2016, 01:55
  • Все хорошо, но почему то у меня не работает SSH. Кто знает в чем может быть дело?

    19 августа 2015, 19:52
  • Здравстуйте. Возник такой вопрос. Если после введения команды «transport input ssh», сеть работает через протокол ssh. то как сделать чтобы она снова могла работать на оба протокола. Пробывал «no transport input ssh» так он поставильв блок и ssh в придачу. Хотя я думал приставка «no»отменяет команду

    10 августа 2015, 10:54
  • Добрый день, благодарю Вас за ваши труды, очень интересно и понятно.
    Вопрос у меня такой, чтоб бы была возможность попасть по телнету я опустил команду aaa new model, дальше вел все как обычно, -username… secret,-enable… secret. Вписал команду -line vty 0 4 и там же просто ввел команду -login local. Telnet стал доступен.
    Сделал тоже самое что вы показали в видео уроке. Все работает.
    Хочу понять в чем разница? Не уже ли только изза «Radius»?

    25 апреля 2015, 13:10
  • На vty рекомендую вешать exec-timeout

    29 марта 2015, 11:42
  • An average of the estimates was found and the most cost-effective strategy is the one with the highest mean INMB. However, the one with the highest mean INMB may or may not be the most cost-effective in all the simulations. The model parameters, the type of distribution and distribution parameters are listed in the table below (table 16. The model input parameters that we did not vary probabilistically are life expectancy of a patient with dementia, survival length of time in long-term care, post-discharge mortality differences for delirious and non-delirious patients, and the discount rate. The result of the deterministic analysis suggests that this intervention is cost- effective when compared to usual care and is associated with an incremental net monetary benefit (INMB) of £2,130. The result of the probabilistic sensitivity analysis (PSA) suggests that the usual care strategy will cost £13,200 on average whereas the prevention strategy will cost £12,690, Levaquin 500mg pills online pharmacy cheap fast Delivery Alabama with Mastercard. Baseline comparability was reported on age, gender, serum urea, serum creatinine levels, and baseline agitation levels. Agitation levels were assessed by a doctor using the modified Cohen-Mansfield Agitation Inventory based on personal observations and discussion with nurses or carers regarding the behaviour of the patient during the previous 48 hours. There was less than 20% missing data, one patient in the subcutaneous group died and one patient in the intravenous group was switched to the subcutaneous route after 24 hours because of difficulties with venous access, Amoxicillin 250 mg capsule no prescription price overnight delivery Oregon. These patients were not included in the analysis. Overall, the study was considered not to be at higher risk of bias, although it only reported indirect outcomes. Bactrim SKUTKI UBOCZNE — forum dyskusje rozmowy. Co do mucosolwanu to pewnie jest to na zlecenie lekarza. To chyba dobry lek przeciwzapalny na pewno lepsze to niż faszerowanie antybiotykami. Ja bactrimu za bardzo nie lubie bo dla mnie bactrim czy antybiotyk to jedno i to samo jesli . Na CO BACTRIM LEK — forum dyskusje rozmowy — Forum.gazeta.pl. Na CO BACTRIM LEK: najświeższe informacje zdjęcia video o NA CO BACTRIM Bactrim to jest antybiotyk zawiera trimetoprim i sulfametoksazol, Co lepsze bactrim czy antybiotyk. Mi też nieraz lekarka sie pyta czy mam w domu jakiś leknp eurespal czy bactrim i jak… podawaliśmy Bactrim powiedział że w dzisiejszych czasach są dużo lepsze leki niż 

    16 января 2015, 17:17
  • While the ascertainment of mortality is less subjective, the baseline differences in populations receiving the interventions in the Miyaji (2007) study makes it difficult to draw any reliable conclusions, simply because the more severely ill patients may have received parenteral haloperidol. Two studies carried out multivariate analyses (Gill 2005; Herrmann 2004). The Gill (2005) study did not take into account confounders such as smoking history, presence and severity of hypertension, lipid status and specific valvular heart conditions, Dosis flagyl 250. At a subsequent meeting, the GDG Chair facilitated a discussion to further refine the questions. The results of this process were then discussed and consensus reached about which questions would be of primary impor- tance and which would be secondary. The GDG aimed to address all primary ques- tions, while secondary questions would only be covered time permitting, Pregnancy category for keflex. The PICO (patient, intervention, comparison and outcome) framework was used to help formu- late questions about interventions., Buy online Antibiotics Ciprowin Cephalexin 250/500/750mg low prices overnight delivery

    16 января 2015, 15:59
  • I wish you prosperity and God bless you! All assignments I’ve ordered with you are perfect, Write research paper persuasive for sale California. Both, term paper on literature and research paper on management were completed on a decent level. More Now Again by Elizabeth Wurtzel Books The Guardian. 9 Feb 2002 I arrive in Florida on Halloween in 1996 and it is so sunny that the I don't need drugs I don't need friends — for all I care the phone can be I owe my publisher a book I will be honourable about completing it. I almost can't help myself. Sometimes I don't mean to be writing it's the last thing I feel like  ». How To Start A Business With Only $100 In The Bank — Forbes, Need help writing my book review now Florida. 31 May 2012 My second book Promote Yourself: The New Rules For Career Success will be released in Why is it possible now to start a company for almost no money? travel creative self-employment writing — that I could in fact monetize. Even if they're small actions the process will help you focus on being  »We understand that in order to order essay writing services. Why Buy Essay Papers Online Essay-papers-for-sale online companies make use of questionnaires that ask relevant questions about the status of your future career, Write essay definition help me. We can write my paper for me services are highly advanced academically and even help the executor and provide him/her with basic material you would like to see, there is a thesis in economics, marketing or psychology – this can be quite challenging, especially if you compare it with the best essay that is why we are aware of such kind of disaster. Some students are increasingly demanding not usual, familiar to a PhD holder, then there is no reason to hesitate just contact us with all the requirements of your essay.

    16 января 2015, 15:37
  • , Antrima 800mg + 160mg capsule generic low cost fast Delivery Michigan with MastercardTheWorldCancerResearchFundschema wastakenasthestartingpointbutwasmodifiedinthefollowingmanner:randomizedcontrolledtrialsweregiven prominenceasthehighestrankingstudydesign (randomized controlled trialswere notamajorsourceofcancer evidence); associated evidence and expert opinion was also taken into account in relation to environmental determinants (directtrialswereusuallynotavailable). Low energy-dense (or energy-dilute) foods, such as fruit, legumes, vegetables and whole grain cereals, are high in dietaryfibreandwater. A high dietary intake of non-starch polysaccharides (NSP)/dietary fibre (protective), Buy online Antibiotics Levoquin Ciprofloxacin 250/500/750/1000mg low prices with VISA in USA . A guide to guidelines for the treatment of PTSD and related conditions. Journal of Traumatic Stress, 23(5), 537-52. Acute traumatic stress symptoms (first month): pharmacological interventions – children and adolescents 88 PART 1: EVIDENCE REVIEW Population/intervention/comparison/outcome (PICO)  Population: Children and adolescents with acute traumatic stress symptoms, 14 within one month of exposure to a potentially traumatic event(s)  Interventions: Pharmacological interventions (benzodiazepines and antidepressants)  Comparison: Placebo/active pharmacological treatment  Outcomes: — Symptom severity post-intervention and at follow-up — Functioning/quality of life post-intervention and at follow-up — Presence of mental disorder post-intervention and at follow-up — Adverse effects (including tolerability). Details of commissioned systematic review NOTE: this systematic review was commissioned for a broader set of scoping questions, including pharmacological interventions for people with bereavement, PTSD and ASD. For this scoping question, the methodology of the review is presented for all studies, but only the results of studies relevant to children and adolescents with acute traumatic stress are discussed. Types of studies All double-blind, randomized, placebo controlled and comparative trials completed between October 2005 and October 2011 were considered in our primary and additional searches, covering 13 separate databases, Will keflex treat sinus infections.

    16 января 2015, 15:35
  • А почему вы подключаете PC к Маршрутизатору через кроссовер? Нужно же использовать прямой кабель, или я ошибаюсь?

    15 октября 2014, 02:29
  • Разве после

    Router(config)#hostname R0

    имя роутера не меняется сразу?
    У Вас после этой команды

    Router(config)#ip domain-name cisco-dmn
    Router(config)#crypto key generate rsa
    Router(config)#line vty 0 4
    Router(config-line)#transport input ssh

    Мелочь, конечно, но все же (не сочтите за снобство)
    За статью спасибо, вы все там красавчики!

    9 июля 2014, 16:41
  • А если у меня cisco 881w, а в packet tracer такого нет, принципиальность использования тех или иных встроенных маршрутизаторов?

    22 мая 2014, 16:38
  • Доброго дня. не могу понять где ошибся, почему не принимает пароль
    User Access Verification

    Password:
    Router>en
    Router>enable
    Password:
    Router#con
    Router#confi
    Router#configure ter
    Router#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#aaa new-
    Router(config)#aaa new-model
    Router(config)#user
    Router(config)#username?
    WORD User name
    Router(config)#username admin?
    WORD
    Router(config)#username admin?
    password Specify the password for the user
    privilege Set user privilege level
    secret Specify the secret for the user
    Router(config)#username admin secr
    Router(config)#username admin secret pass
    Router(config)#username admin secret pass
    Router(config)#username admin secret?
    0 Specifies an UNENCRYPTED secret will follow
    5 Specifies a HIDDEN secret will follow
    LINE The UNENCRYPTED (cleartext) user secret
    Router(config)#username admin secret 5?
    5 LINE
    Router(config)#username admin secret 5 admin
    Router(config)#exit
    Router#write
    Building configuration…
    [OK]
    Router#exit

    [Connection to 192.168.1.1 closed by foreign host]
    PC>telnet 192.168.1.1
    Trying 192.168.1.1 …Open

    User Access Verification

    Username: admin
    Password:
    % Login invalid

    User Access Verification

    Username:
    User Access Verification

    Username: admin
    Password:

    [Connection to 192.168.1.1 closed by foreign host]
    PC>

    10 апреля 2014, 13:25
  • Перечитываю, по второму кругу, статьи данного цикла. Появился вопрос: «В начале данной статьи, в разделе „Среда“ говорится что PT — является эмулятором, а GNS3 — симулятором, так ли это?». Всегда считал наоборот.

    5 февраля 2014, 14:35
  • Делал всё как написано, дошёл до «Если вы хотите ограничить паролем доступ через консольный порт, вам понадобятся команды».
    Ввёл команды, в ответ:

    Router(config)#line console 0
    Router(config-line)#login
    % You can only use the command "[no] login authentication …" when aaa is enabled

    Что делать?

    21 января 2014, 21:05
  • Здравствуйте.
    При подключении telnetом условие нахождения в одной подсети устройства и коммутатора обязательны?
    В том плане если брать настроенную сеть из второй части, то как подключиться к коммутатору(telnetом) если сетевой интерфейс какого-либо компьютера уже настроен на другую сеть?

    25 ноября 2013, 01:25
  • А почему у меня
    PC>ssh -1 admin 192.168.1.1
    Invalid Command.

    не могу зайти через ssh. telnet закрыл.

    15 ноября 2013, 15:47
  • Такой вопрос, в Packet Tracer-6 после выключения\включения роутера исчезают все настройки.
    Это какой-то глюк или я чего то не понимаю. На хосте Ip остается после точно таких же действий.
    Роутер как будто ресетнул, а не выключил.

    23 октября 2013, 13:45
  • Подскажите, при фильтрации вывода можно ли комбинировать слова фильтра?
    К примеру, на команду

    Switch#sh int | include CRC

    я получаю таблицу типа такой:

    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

    Она трудно читается для, скажем, 24 интерфейсов.
    Хотелось бы добавить к CRC ещё, например, FastEthernet и получить что-то типа такого:

    FastEthernet0/1 is down, line protocol is down (disabled)
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

    FastEthernet0/2 is down, line protocol is down (disabled)
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

    7 августа 2013, 10:06
  • Router(config)#aa
    Router(config)#aaa new
    Router(config)#aaa new-model
    Router(config)#user
    Router(config)#username?
    WORD User name
    Router(config)#username admin?
    password Specify the password for the user
    privilege Set user privilege level
    secret Specify the secret for the user
    Router(config)#username admin pass
    Router(config)#username admin password cisco

    4 августа 2013, 17:49
  • в чем проблема все делал как на видио а он
    PC>telnet 192.168.1.1
    Trying 192.168.1.1 …Open

    [Connection to 192.168.1.1 closed by foreign host]
    PC>telnet 192.168.1.1
    Trying 192.168.1.1 …Open

    User Access Verification

    Username: admin
    Password:
    % Login invalid

    User Access Verification

    Username:
    User Access Verification

    Username: admin
    Password:

    [Connection to 192.168.1.1 closed by foreign host]

    4 августа 2013, 17:43
  • Василий Теркин

    интересно а почему на свитче 2960 я не огу ввести
    Router(config)# interface fa0/0

    По умолчанию все интерфейсы отключены (состояние administratively down). Включаем интерфейс:

    Router(config-if)#no shutdown

    Настроим IP-адрес:

    Router(config-if)#ip address 192.168.1.1 255.255.255.0

    где то вычитал что можно(и опробывал — можно) что вместо Router(config)# interface fa0/0 можно ввести команду относительно Vlan 1 (существующего по умолчанию в неактивном режиме)и настроить IP адресс свитча в этом VLAN — но если так то компы не изначально не видят VLAN1 и соответственно
    не видят свитча. Да и ВЫлан мне пока не нужны

    Как быть если по IP свитча мне нужен доступ со всех сетевых (физических) интерфейсов свитча?
    интересно как будет вести себя настоящая железка каталист 2960 28+4 портов c PoE (я так понял что это свежая железка и тут примера не нее нет ?)?

    6 июля 2013, 17:24
  • А режим AAA можно только на роутерах включать? Если да, то есть ли возможность на свичах cisco для настройки привилегий?

    15 мая 2013, 18:01
  • Георгий Владимиров

    Доброе утро! Про сброс пароля отдельно от сброса всего конфига устройства не слышал. Полагаю, в природе существует только сброс конфига.

    5 января 2017, 11:14
  • Георгий Владимиров

    разобрался. конфигурировать можно сразу все 16 линий выражением line vty 0 15. ios сам разобьёт их на два диапазона. буду рад если кто-нибудь подскажет по следующим вопросам:

    — в пт? ааа для свитчей кроме 3560 не реализовано, или так и есть в жизни?
    — ипв6 в пт на 3560 реализован нормально? странно, что пинг с пк пошёл лишь после пинга с роутера на него самого.
    — если настройка производится через vty, а не через ааа, то есть ли возможность шифровать пароль на терминал в теле конфига? или это снова недоделка пт?
    — часть статьи про сброс, видимо не совсем актуальна. недавно сбрасывал 2960, сколько брейк не посылал, всё равно. решилось зажиманием кнопки на лицевой панеле.

    13 августа 2016, 05:43
  • Георгий Владимиров

    таким образом, если пароль задаётся через виртуальные терминалы, надо паролить два диапазона этих терминалов в дефолтном конфиге — 0-4 и 5-15. есть ли возможность отключить какой-то диапазон vty насовсем или скажем конфигурировать их всех одной пачкой в 16 штук? может быть это особенность реализации в пт?

    13 августа 2016, 02:03
  • Как мысль: Попробуй вместо -1 (дефис один) написать (дефис L (маленькая) от слова login)

    12 апреля 2016, 08:04
  • Добрый день.
    Вероятно, вам поможет команда

    transport input ssh telnet
    13 августа 2015, 11:34
  • Извините, где вы это увидели? В РТ можно подключать только кросс-овером, во всяком случае в той версии, в которой я делал урок.

    15 октября 2014, 19:21
  • Хорошее замечание. Спасибо. Исправлено.

    13 июля 2014, 15:55
  • Главное, чтобы вы поняли для начала технологии и протоколы. Базовые вещи можно отработать на чём угодно практически. А вот если вам нужны какие-то детали, особенности работы протокола на определённой железке, тогда вам РТ не подходит.

    22 мая 2014, 16:51
  • Все огромное спасибо разобрался))
    если кому то надо то лог того что сделано прям пошагово:
    Router(config)# interface fa0/0
    Router(config-if)#no shutdown
    Router(config-if)#ip address 192.168.1.1 255.255.255.0
    Router(config)#line vty 0 4
    Router(config-line)#password cisco
    Router(config-line)#login local
    Router(config)#username admin1 secret pass1
    Router(config)#enable secret test
    Router(config)#aaa new-model
    Router(config)#aaa authentication login LOCAL_USERS local
    Router(config)#line vty 0 4
    Router(config-line)#login authentication LOCAL_USERS
    Router(config-line)#exit
    Router(config)#exit
    Router#write
    Building configuration…
    [OK]
    Router#exit

    [Connection to 192.168.1.1 closed by foreign host]
    PC>telnet 192.168.1.1
    Trying 192.168.1.1 …Open

    User Access Verification

    Username: admin1
    Password:
    Router>
    в итоге подключаемся по логину admin1 пароль pass1
    если что то не так или хромает безопасность скажите кому не трудно

    10 апреля 2014, 16:44
  • только что попробовал в гнс, все работает…

    10 апреля 2014, 16:21
  • *в режиме PacketTracer

    10 апреля 2014, 15:45
  • хм… не работает(конечно может быть из-за того что в режиме PC, циски под руками нет, проверит не на чем), но вот что делал и все равно не пускает
    Router(config)#username admin sec
    Router(config)#username admin secret 0 pass
    Router(config)#aaa new
    Router(config)#aaa new-model
    Router(config)#aaa auth
    Router(config)#aaa authe
    Router(config)#aaa authentication login admin local
    Router(config)#lin
    Router(config)#line vty 0 15
    Router(config-line)#
    Router(config-line)#login authr
    Router(config-line)#login auth
    Router(config-line)#login authentication admin
    Router(config-line)#exit
    Router(config)#exit
    Router#write me
    Router#write memory
    Building configuration…
    [OK]
    Router#exit

    [Connection to 192.168.1.1 closed by foreign host]
    PC>telnet 192.168.1.1
    Trying 192.168.1.1 …Open

    User Access Verification

    Username: admin
    Password:
    % Login invalid

    10 апреля 2014, 15:42
  • блин, отправилось сообщение раньше.
    username admin secret pass
    aaa new-model
    aaa authentication login LOCAL_USERS local
    line vty 0 15
    login authentication LOCAL_USERS

    10 апреля 2014, 15:06
  • вот плюс к тому, что вы написали, еще 2 строчки, которые я написал.
    username admin secret pass

    Вообще это место в статье нужно переписать, как-то неточно описано…

    10 апреля 2014, 15:02
  • а можно прям построчно)) я откатился назад путем no aaa new-model и теперь у меня заходит по телнету, но как настроить связку логин/пароль через ААА
    (уж не пинайте сильно только начал изучать, многое не ясно)

    10 апреля 2014, 14:54
  • для того, чтобы использовать локальных пользователей при включенном aaa new-model, нужно дополнительно создать ААА-лист и применить его на нужные lines. например:
    aaa authentication login LOCAL_USERS local
    потом заходим на vty и\или con и пишем
    login authentication LOCAL_USERS

    10 апреля 2014, 13:41
  • Спасибо за пояснение, а то я уже начал сомневаться 🙂

    6 февраля 2014, 13:09
  • Денис, вы правы.
    Даже в одном из выпусков об этом речь была: linkmeup.ru/blog/91.html
    Спасибо за замечание.

    6 февраля 2014, 13:01
  • Ок, если что — буду ждать отдельной статьи, всё таки AAA более правильная вещь, как мне кажется. Спасибо.

    22 января 2014, 12:00
  • вопрос очень большой и отдельный по AAA. Не рассмотрен тут, потому что по умолчанию AAA выключен.

    22 января 2014, 11:59
  • Получается так, что в статье этот вопрос не рассмотрен. То есть если всё делать строго по инструкции (а самые маленькие по-другому и не умеют), то будет выдавать ошибку. Чтобы ошибку не выдавало — нужно сделать что-то ещё, не описанное в статье. Имеет смысл обновить?

    22 января 2014, 11:55
  • тогда вместо login (login local) используйте login authentication c указанием группы аутентификации (ее надо предварительно настроить). Рекомендую не делать этого на нужном оборудовании, если четко не понимаете, что делаете, есть немаленькая вероятность того, что вы закроете таким образом себе доступ на железку.

    22 января 2014, 09:14
  • А если я хочу с использованием aaa new-model?

    21 января 2014, 21:08
  • ровно то, что сказали: отключить AAA: no aaa new-model

    21 января 2014, 21:07
  • все просто — у вас вместо символа «l» скорее всего введена единица «1», проверьте

    19 декабря 2013, 19:53
  • Здравствуйте.Аналогичная проблема. Подскажите что делать?

    2 декабря 2013, 08:45
  • Здравствуйте.

    Разумеется, необязательно.

    В этом выпуске мы как раз рассказываем о маршрутизации.

    25 ноября 2013, 11:13
  • Все сделал по видео\тексту, работает =)

    23 октября 2013, 16:36
  • Мда, ее то я и не выполнил видимо)) спасибо.

    23 октября 2013, 14:47
  • То есть вы выполняете команду

    write memory

    , всё без ошибок сохраняется, но после рестарта конфигурация пустая?
    Так происходит на любых устройствах (разные коммутаторы/маршрутизаторы)?

    23 октября 2013, 13:52
  • Только для каждого интерфейса разве что делать выборку, кстати section что выводит в данном примере?
    Кстати у меня почему то в PT не работает выборка "|", пробывал разные свитчи/роутеры, нет ее почему то возможности использовать. PT 6 версии

    17 октября 2013, 12:54
  • К сожалению, насколько мне известно, настолько гибко сделать это нельзя.

    7 августа 2013, 11:10
  • В настройках line vty 0 4 нужно выставить login local, насколько я помню.

    5 августа 2013, 03:05
  • Вы имеете ввиду, что не можете ввести ip address …? Это потому, что все физические интерфейсы 2960 — L2 интерфейсы и не могут иметь IP-адреса.

    но если так то компы не изначально не видят VLAN1

    Как так? Конечно должны видеть — VLAN1 — это влан по умолчанию на всех управляемых коммутаторах, то есть по умолчанию все порты находятся именно в первом влане.

    И, как вы можете видеть из этого цикла, именно так и поступают — адрес управления настраивают на влан-интерфейсе (1-м или не 1-м не имеет значения).

    6 июля 2013, 19:09
  • 1) зависит от версии CatOS
    2) тут уже зависит от свича. если на нем CatOS, то там привелегии либо 0, либо 15, а если IOS, то можно, как обычно.

    15 мая 2013, 18:36

Ещё статьи

Как запустить форум за один вечер
Наш проект CCIE за год семимильными шагами приближается к своему старту. Летят эссе в преддедлайновой агонии. Меж тем надо запускать форум. Тут следует сделать анонс — у нас будет два ...
like 0 3953 4
12 марта 2016
Анонс подкаста. Выпуск 51. Сетевики скоро будут не нужны ///UPD: Эфир закончен
Когда: 14.05.2017 в 15:00 (МСК) Кто: Алексей Учакин. Сетевой инженер, автор блога nixman.info.Наташа Самойленко. Автор курса “Python для сетевых инженеров”Дмитрий Фиголь. Инженер ТП вендора. Главный апологет автоматизацииАлександр Клиппер. AmazonПро что: ...
like 282 11355 7
30 апреля 2017
Wireshark - приручение акулы
Автор статьи Александр Sinister. Специально для проекта linkmeup. ============= Wireshark — это достаточно известный инструмент для захвата и анализа сетевого трафика, фактически стандарт как для образования, так и для траблшутинга. ...
like 1 77174 13
2 декабря 2013